Error on Checkout Page for splice.com
Incident Report for Splice
Resolved
The issue has been found and corrected
Posted Sep 13, 2024 - 18:48 UTC
Update
We are actively investigating root cause and are in contact with our Payment Provider.
Posted Sep 13, 2024 - 14:53 UTC
Investigating
Users are currently seeing an error on the checkout page of splice.com. We are currently investigating the issue.
Posted Sep 13, 2024 - 14:14 UTC