Investigating Issue with degraded performance due to the AWS outages

Incident Report for Splice

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 12:10 UTC

Monitoring

We're continuing to see degraded load times due to ongoing issues with LaunchDarkly. We'll continue to monitor and provide updates as we get them.
Posted Oct 21, 2025 - 00:34 UTC

Update

We're continuing to see and address issues related to AWS outages, we will provide another update in 1 hour
Posted Oct 20, 2025 - 23:23 UTC

Investigating

Several pages and experiences across the Splice.com site are experiencing degraded performance due to the AWS outages affecting downstream services including LaunchDarkly.
Posted Oct 20, 2025 - 20:18 UTC