Logged in users may have issues accessing plugin product pages

Incident Report for Splice

Resolved

The incident is resolved--plugin description pages are again accessible to all users.
Posted Nov 05, 2025 - 16:59 UTC

Investigating

The problem change has been identified and is being rolled back.
Posted Nov 05, 2025 - 16:53 UTC