Free plugins are not downloadable

Incident Report for Splice

Resolved

Root cause has been found and the issue is now resolved.
Posted Nov 10, 2025 - 21:06 UTC

Investigating

We are currently investigating this issue.
Posted Nov 10, 2025 - 19:00 UTC