Splice Discord users unable to link their Splice accounts
Incident Report for Splice
Resolved
Splice Discord users should now be able to link their Splice and Discord accounts.
Posted Oct 28, 2022 - 20:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2022 - 20:50 UTC
Investigating
We are currently investigating this issue.
Posted Oct 28, 2022 - 18:48 UTC