Degraded Performance and Functionality With Some Search Queries

Incident Report for Splice

Resolved

All search functionality restored.
Posted Apr 28, 2026 - 21:41 UTC

Identified

Root cause has been discovered and we're beginning mitigation steps.
Posted Apr 28, 2026 - 21:16 UTC

Investigating

Currently investigating root causes and looking to begin mitigation steps.
Posted Apr 28, 2026 - 21:02 UTC